Re: [squid-users] More WCCP woes

From: Joe Cooper <joe@dont-contact.us>
Date: Tue, 13 Mar 2001 18:31:33 -0600

Try using the ip_wccp module...it seems easier to make it work in most
cases (though I've never had a problem getting the patched GRE module to
work either--you did patch your ip_gre module, didn't you?).

I've converted it into a kernel patch that applies cleanly to 2.2.18,
and can be configured at compile time as a module. Then it's just a
modprobe away from working. No messing about with creating a gre interface.

The patch is here:

http://www.swelltech.com/pengies/joe/patches/

It's the last link on the page.

Also, you asked how the router knows about the cache...it isn't a
broadcast protocol, the Squid announces itself to the router (because
you've configured the router in the wccp_router directive) with a
"HERE_I_AM" packet, which the router responds to with a "I_SEE_YOU"
packet. The GRE encapsulation is then used to send the packets to the
Squid box, which then get decapsulated by the OS.

Hope this helps.

Curtis E. Hays II wrote:

> Apparently I'm not trying enough to get wccp working.... any help would be
> appreciated.. here are my current non-working configs...
>
>
> Cisco router config:
> ip subnet-zero
> ip wccp version 1
> ip wccp web-cache
> !
> !
> !
> !
> interface FastEthernet0/0
> ip address 172.17.104.52 255.255.255.0
> ip broadcast-address 172.17.104.255
> ip wccp web-cache redirect out
> duplex auto
> speed auto
> !
>
> (relevant parts)
>
> running ios: IOS (tm) 3600 Software (C3640-I-M), Version 12.1(1)T,
> RELEASE
> SOFTWARE (fc1)
>
> I've compiled my Linux kernel ver 2.2.18 with the ip_wccp.c patch... I'm
> running squid 2.4PRESTABLE2 in http accel mode... I've got a windows box
> with a default gw of the cisco router and the squid on the same segment.
> The cisco config doesn't show any way to communicate with the squid i.e.
> you
> don't configure an IP??? is it a broadcast protocol that they are
> supposed
> to see each other? The cisco doesn't show it:
>
> wccp-rtr#sh ip wccp
> Global WCCP information:
> Router information:
> Router Identifier: 172.17.104.52
> Protocol Version: 1.0
>
> Service Identifier: web-cache
> Number of Cache Engines: 0
> Number of routers: 1
> Total Packets Redirected: 0
> Redirect access-list: -none-
> Total Packets Denied Redirect: 0
> Total Packets Unassigned: 0
> Group access-list: -none-
> Total Messages Denied to Group: 0
> Total Authentication failures: 0
>
> I've got IPCHAINS configured on the linux box to redirect port 80
> traffic to
> port 3128, but it doesn't look like the cisco even sees the wccp enabled
> linux box/squid....
>
> I didn't get the mention of configuring a GRE tunnel on the Linux box,
> so I
> configured a GRE tunnel up... no ip or anything... just up... then with
> an
> IP on the same network. using :
>
>
> iptunnel add gre1 mode gre remote <Router-IP> local <Host-IP>
> dev
> <interface>
> ifconfig gre1 127.0.0.2 up
>
> still didn't see anything on the cisco when doing 'sh ip wccp'
>
> so I tried building the other end of the gre tunnel on the cisco with :
>
> interface Tunnel0
> ip address 1.1.1.1 255.255.255.0
> ip broadcast-address 1.1.1.255
> tunnel source FastEthernet0/0
> tunnel destination 172.17.104.132
>
> nothing working yet :(
>
> so I tried this:
>
> interface Tunnel0
> ip address 1.1.1.1 255.255.255.0
> ip broadcast-address 1.1.1.255
> tunnel source FastEthernet0/0
> tunnel mode ipip decapsulate-any
>
> Still no cache engine showing up with 'sh ip wccp' on the router.
>
> ANY help would be appreciated... I've been goveling over the mailing
> list
> archives and can't seem to find the question or answer previously
> answered.
>
> Thanks,
> Curtis Hays

                                   --
                      Joe Cooper <joe@swelltech.com>
                  Affordable Web Caching Proxy Appliances
                         http://www.swelltech.com
Received on Tue Mar 13 2001 - 17:34:19 MST

This archive was generated by hypermail pre-2.1.9 : Tue Dec 09 2003 - 16:58:38 MST